• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item6316: ALLVARIABLES doesn't work as expected for subwebs

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal New   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

Say we have a web and a subweb, Learn and Learn/Demo.

In Learn.WebPreferences we have

   * Set ALLOWWEBCHANGE = MyGroup 

In Learn/Demo.WebPreferences we have

   * Set Set ALLOWWEBCHANGE = StaffGroup 

When I run %ALLVARIABLES% from a Topic in Learn/Demo I expect to see both

WEB Learn/Demo.WebPreferences
Set final ALLOWWEBCHANGE
Main.StaffGroup 

and

WEB Learn WebPreferences
Set final ALLOWWEBCHANGE
Main.MyGroup 

Instead, I only see the ALLOWWEBCHANGE setting for the Learn web.

-- TWiki:Main/VickiBrown - 30 Aug 2009

ItemTemplate
Summary ALLVARIABLES doesn't work as expected for subwebs
ReportedBy TWiki:Main.VickiBrown
Codebase 4.2.4
SVN Range TWiki-5.0.0, Sat, 18 Apr 2009, build 18024
AppliesTo Engine
Component

Priority Normal
CurrentState New
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Topic revision: r1 - 2009-08-30 - VickiBrown
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback