• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item6269: ApacheLogin triggers TWiki::Users::TWikiUserMapping bugs

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal New   patch  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

context

Faults seen after upgrade from 4.2.3 to 4.3.1.

config

  • $TWiki::cfg{LoginManager} = 'TWiki::LoginManager::ApacheLogin'
  • $TWiki::cfg{Register}{AllowLoginName} = 0

symptoms

view: Use of uninitialized value in string eq at /var/www/twiki/lib/TWiki/Users/TWikiUserMapping.pm line 471.

view: Can't call method "normalizeWebTopicName" on an undefined value at /var/www/twiki/lib/TWiki/Func.pm line 1306.

discussion

Errors occur in browser when trying to view a page.

I can't adequately explain why this problem occurs, except that it has to do with the TWiki singleton's constructor calling functions in other classes that refer to TWiki object properties that haven't been set yet.

Please review the attached patch; it should give a good overview.

-- TWiki:Main/TomaszGrzegurzko - 29 May 2009

This needs to be investigated. What is the {UserMappingManager} and {PasswordManager}?

-- TWiki:Main.PeterThoeny - 01 Jun 2009

I'm seeing the same issue with TWikiUserMapping.pm line 471 on a brand new 4.3.1 install. wiki admin doesn't generate the error, only users that are created generate them. It happens for every page turn. Seems like everything is working while still generating the error. I also had ApacheLogin set at one point, so I'm not sure if that contributed to the issue. I have the following config:

$TWiki::cfg{UserMappingManager} = 'TWiki::Users::TWikiUserMapping'; $TWiki::cfg{PasswordManager} = 'TWiki::Users::HtPasswdUser'; $TWiki::cfg{LoginManager} = 'TWiki::LoginManager::TemplateLogin';

-- TWiki:Main.MarioScubla - 25 Aug 2009

ItemTemplate
Summary ApacheLogin triggers TWiki::Users::TWikiUserMapping bugs
ReportedBy TWiki:Main.TomaszGrzegurzko
Codebase 4.3.1
SVN Range TWiki-5.0.0, Sat, 18 Apr 2009, build 18024
AppliesTo Engine
Component

Priority Normal
CurrentState New
WaitingFor

Checkins

TargetRelease patch
ReleasedIn

Topic attachments
I Attachment History Action Size Date Who Comment
Unknown file formatpatch user_init_fix.patch r1 manage 5.9 K 2009-05-29 - 08:33 TomaszGrzegurzko Patch to TWiki lib code (v4.3.1) to fix initialisation dependency bugs
Edit | Attach | Watch | Print version | History: r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r3 - 2009-08-25 - MarioScubla
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback