• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item6149: Error saving TWikiAdminGroup topic with UTF-8

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal New   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

Reported by TWiki:Main/LyleHopkins in TWiki:Support/BUGWideCharacterInPrint :
From a fresh install of the latest TWiki 4.2.3 a problem is encountered when editing the page:- TWikiAdminGroup? for the first time.

The BUG results in the error:-

##### Error start ##### Attention

Error saving topic During save of TWikiAdminGroup an error was found by the version control system. Please notify your TWiki administrator.

Wide character in print at /home/cosmictest/domains/twiki.cosmictest.com/public_html/twiki/lib/TWiki/Store/RcsFile.pm line 797. .... lots more errors ##### Error End #####

This occurs whether RcsWrap? or RcsLite? is selected.

The problem is caused by an invalid character on the default TWikiAdminGroup? page. This character is used to make the yellow box around the instructions on adding users to the group.

In FireFox? 3.0.3, a box with 4 zeros is displayed (two on top of two) instead of the character. This appears either site of "stick0" near the top and "stick1" near the bottom.

If you try and save the page leaving in the invalid character you'll get the save error above and lose the whole page.

Under IE 7.0.6

The invalid character is displayed as � again either side of the stickys. You can save the page, but the yellow box disappears, and when you edit again the character has gone and you are simply left with the two pieces of text, sticky0 and sticky1.

Either way this certainly isn't acting as it should.

And TWiki:Main/DavidFoerster writes:

I also experienced this bug with a new TWiki installation configured to use UTF-8. It should be trivial to figure out by which characters the sticky0 and sticky1 statements are enclosed and why the cause problems with UTF-8 setups.

-- TWiki:Main/PeterThoeny - 13 Dec 2008

ItemTemplate
Summary Error saving TWikiAdminGroup topic with UTF-8
ReportedBy TWiki:Main.PeterThoeny
Codebase 4.2.3
SVN Range TWiki-5.0.0, Wed, 22 Oct 2008, build 17677
AppliesTo Engine
Component

Priority Normal
CurrentState New
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Topic revision: r1 - 2008-12-13 - PeterThoeny
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback