• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item5727: configure and perl 5.10 dies with Use of uninitialized value $filename in substitution (s///) at (eval 41) line 23

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Urgent Closed   patch 4.2.1, 5.0.0

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

I read about a lot of trouble running configure on the Support web

It seemed to be related to perl 5.10

I decided to install Fedora core 9 on a virtual machine.

And the obervation reported is now confirmed.

On a fresh install - in this case of TWikiRelease04x02rev 16925 - and setting up LocalLib.cfg correctly - you can startup configure. But the minute you try to save by hitting the "next" button configure dies reporting

Use of uninitialized value $filename in substitution (s///) at (eval 41) line 23.

Only trace in the error_log is

[Mon Jun 23 07:25:00 2008] [error] [client 127.0.0.1] [Mon Jun 23 07:25:00 2008] configure: Use of uninitialized value $filename in substitution (s///) at (eval 41) line 23., referer: http://localhost/twiki/bin/configure

which does not add more information.

So next step is to try and debug this and try to find out what is triggering this error. It is probably not the last error we see related to perl 5.10

But all the large distros ship with 5.10 now so we have to work with 5.10 for 4.2.1

-- TWiki:Main/KennethLavrsen - 23 Jun 2008

References:

-- TWiki:Main.KennethLavrsen - 23 Jun 2008

According to some support issues in IRC, other OSs might be affected, too. The two or three people I spoke to, had MacOS and NetBSD installed.

-- TWiki:Main.OliverKrueger - 23 Jun 2008

I have a proplem tracing the actual error. I have tried to add some additional debugging to configure using some hints on the net.

Anyone has a good way to get a full trace down to the library that fails? I am convinced the actual uninitialized substitution happens in a CPAN lib triggered by us not setting up something that older versions of the lib did not need or defaulted well.

-- TWiki:Main.KennethLavrsen - 23 Jun 2008

With a modified configure I get more in the error_log. But I am not much nearer a solution.

Why must configure die on warnings?

-- TWiki:Main.KennethLavrsen - 24 Jun 2008

the really odd thing about this, is that I have been running twiki 4.2 and trunk on perl 5.10 (on debian) for some months, and my configure works fine.

-- TWiki:Main.SvenDowideit - 25 Jun 2008

It is probably related to a specific version of one of the CPAN libs that comes with the distribution.

Sven can you give some advice how I get get a better stack trace so we can see both which CPAN libs that barfs and how it is called. I have tried many things incl what you see in the attachment to this report and I am kind of running out of ideas how to debug further.

-- TWiki:Main.KennethLavrsen - 25 Jun 2008

The error is in the perl CPAN library CGI.

version 3.37 is know to be buggy and maybe also previous versions. 3.15 is know to now have the problem for sure and probably also versions later.

The error happened when TWiki does this very basic command

$query = new CGI

There are known recorded bugs about this.

which is fixed in 3.38 which was released the 25 Jun 2008 (the day I write this)

We have confirmed upgrading to CGI 3.38 cures the problem.

To verify yourself.

perl -e 'use CGI; print "$CGI::VERSION\n";'

Depending on which distro you use and when you read this, your package manager may already have a new perl for you with a newer CGI. The CGI CPAN lib is normally bundled with perl and not in its own package.

If you do not have an update you can update using CPAN.

perl -MCPAN -e 'upgrade CGI'

which upgrades just CGI to the latest version.

If you are on a shared host - contact your system administrator and ask him to update the CGI CPAN library. Even if configure works without the -w in the shebang line TWiki itself may later show problems and your shared host may be flooded with warning messages.

I see no other action on this than updating the support requests and the known issues topic.

-- KennethLavrsen - 25 Jun 2008

found a way to help this cat.

-- SvenDowideit - 17 Jul 2008

ItemTemplate
Summary configure and perl 5.10 dies with Use of uninitialized value $filename in substitution (s///) at (eval 41) line 23
ReportedBy TWiki:Main.KennethLavrsen
Codebase 4.2.1
SVN Range TWiki-5.0.0, Sun, 01 Jun 2008, build 16865
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins TWikirev:17039 TWikirev:17040
TargetRelease patch
ReleasedIn 4.2.1, 5.0.0
Topic attachments
I Attachment History Action Size Date Who Comment
Texttxt error_log.txt r1 manage 16.1 K 2008-06-24 - 06:33 KennethLavrsen Error log of configure modified to talk more in the log
Edit | Attach | Watch | Print version | History: r11 < r10 < r9 < r8 < r7 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r11 - 2008-08-04 - KennethLavrsen
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback