• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item5662: No wysiwyg after update in 4.1.2

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Extension TinyMCEPlugin Normal Closed TWiki:Main.FrederikBeun, TWiki:Main.IanClancy n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

After upgrading the wysiwyg and tiny plugin in the configure, my editor doen't appear anymore. I saw now that on the help page of Tiny you say installing via config from 4.2.0 but nothing is written on what to do for previous versions.

New version of plugins as of today, used IE7. Never had such problems before with the Tiny editor (upgraded from version 20 march)

Can you help me, what possibily could be wrong. Can I fix this?


I just tested the latest uploads with 4.1.2 and it all works perfectly.

The only thing that changed recently in the Tiny MCE plugin is the way the editor finds the textareas it is to camp on. it does this by looking for a textarea with one of the CSS styles = twikiTextarea= (for 4.2.0) or twikiEditboxStyleProportional. If your edit textarea doesn't have either of these styles (e.g. because you are using an odd skin) then it may look like the plugin isn't working. 4.1.2 Pattern skin had the twikiEditboxStyleProportional style on the textarea by default.

Another possiblity is you have the plugin configured not to edit pages that contain calls, or you have disabled the plugin in that web/topic (or some other constraint)

Setting no action as I'm confident the plugin works with 4.1.2

-- CrawfordCurrie - 29 May 2008

I reopened it because I cannot find anything.

I attached the html source as I can see in IE7, and in this file you can see the twikiEditboxStyleProportinal style.

I checked twiki settings and deleted everything that is on tiny

It is on every page on every web

Can you see something strange on the html thanks,

-- TWiki:Main.FrederikBeun - 29 May 2008

No, the HTML looks fine. Check your javascript console for errors (after making sure that javascript is enabled in the browser).

-- TWiki:Main.CrawfordCurrie - 29 May 2008

Lowering this to normal. This bug is about Wysiwyg compatibility with older TWikis. It may trigger a later plugin update but should not block 4.2.1.

-- KennethLavrsen - 02 Jun 2008

I also have the same problem in TWiki 4.1.1.The only error i can see in the error console in Firefox 3 is this:

Warning: Unknown property 'text-overflow'. Declaration dropped. Source File: http://mywiki.lan/pub/TWiki/PatternSkin/style.css Line: 613

-- TWiki:Main.IanClancy - 02 Jul 2008

On reviewing again I note that on Frederik's example page that the editor is set up using editor_selector:twikiTextarea. The editor_selector is used to specify the CSS class name of the text areas to camp on (see http://wiki.moxiecode.com/index.php/TinyMCE:Configuration/editor_selector). Since the textarea in Frederik's HTML does not have this class, the editor doesn't know it's supposed to sit on that textarea.

This is probably the result of modifying TinyMCEPlugin locally. To fix this problem, manually add the twikiEditboxStyleProportional to the editor_selector option defined in TinyMCEPlugin, as described in the TinyMCE configuration help.

Chances are that Ian is encountering the same problem.

-- CrawfordCurrie - 03 Jul 2008

Yes, this appears to have partially fixed the problem for me. When i create new topics with the Create New Topic link on the left hand side of the screen TinyMCE is used. Also when i edit these new topics, TinyMCE is also used. However, when i edit an existing topic (created before TinyMCE install) the old editor is used ?

-- TWiki:Main.IanClancy - 08 Jul 2008

This problem appears on fresh installation of TWiki 4.1.2 and TinyMCE installed using configure, so it is not due to local modifications.

Please add information about this bug to installation page, I have spent a lot of time today trying to figure out why TinyMCE is not appearing and I suspect a lot of users will have the same problem.

The fix with setting editor_selector to twikiEditboxStyleProportional works. For users which do not know how to do it: edit TWiki/TinyMCEPlugin page and change editor_selector setting in "Set INIT" line.

-- TWiki.Main:KrzysztofLichota

-- TWiki:Main.KrzysztofLichota - 17 Jul 2008

I cannot see this is waiting for feedback.

Seems to me to be a doc fix that is required for Wysiwyg for those that upgrade the plugins for an older TWiki.

-- TWiki:Main.KennethLavrsen - 26 Jul 2008

I am closing this old item, seems to be fixed now.

-- TWiki:Main.PeterThoeny - 2013-10-02

ItemTemplate
Summary No wysiwyg after update in 4.1.2
ReportedBy TWiki:Main.FrederikBeun
Codebase 4.1.2
SVN Range TWiki-5.0.0, Tue, 27 May 2008, build 16846
AppliesTo Extension
Component TinyMCEPlugin
Priority Normal
CurrentState Closed
WaitingFor TWiki:Main.FrederikBeun, TWiki:Main.IanClancy
Checkins

TargetRelease n/a
ReleasedIn

Topic attachments
I Attachment History Action Size Date Who Comment
Texttxt HTMLSourceEditPage.txt r1 manage 17.6 K 2008-05-29 - 13:30 FrederikBeun html code from edit page, which does not show tiny editor
Edit | Attach | Watch | Print version | History: r12 < r11 < r10 < r9 < r8 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r12 - 2013-10-02 - PeterThoeny
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback