• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Item5032: templatetopic parameter is ignored

Item Form Data

AppliesTo: Component: Priority: CurrentState: WaitingFor: TargetRelease ReleasedIn
Engine   Normal Closed   n/a  

Edit Form Data

Summary:
Reported By:
Codebase:
Applies To:
Component:
Priority:
Current State:
Waiting For:
Target Release:
Released In:
 

Detail

When you create a new bug here in the Bugs web it is supposed to use the WebTopicEditTemplate topic ( templatetopic=WebTopicEditTemplate). However, a blank page shows up.

The Bugs.WebTopicEditTemplate topic contains this signature:

-- TWiki:Main/%WIKINAME% - %DATE%

Setting this to urgent since it breaks TWiki applications. If no time to fix I suggest to release rc1 regadless of this bug.

-- TWiki:Main.PeterThoeny - 25 Nov 2007

What is this bug exactly? Is it BugsContrib related? Or have all templatetopic parameters stopped working?

-- TWiki:Main.ArthurClemens - 02 Dec 2007

It looks like it is core related since the link in the sidebar to create a new bug item specifies a templatetopic=WebTopicEditTemplate parameter. The WebTopicEditTemplate topic text does not show up in the new topic.

-- TWiki:Main.PeterThoeny - 03 Dec 2007

Peter, can you verify that in a simpler test case than BugsContrib, please? I am using these mechanisms on a daily base in all of my apps and had no problems so far.

-- TWiki:Main.MichaelDaum - 03 Dec 2007

Bouncing this back. I think I gave enough details. Please read my initial problem description again.

-- TWiki:Main.PeterThoeny - 04 Dec 2007

Someone hinted in the release meeting that this is caused by a ItemAUTOINC1 topic that exists. Proper fix is to calculate the actual topic name and to do that exist check with that topic, not with the AUTOINC1 in the topic name.

-- TWiki:Main.PeterThoeny - 04 Dec 2007

you cannot calculate the new topic name until save - otherwise you get a race condition you have to try to work around.

-- TWiki:Main.SvenDowideit - 04 Dec 2007

Seems to be fixed. Dropping to normal before closing. Was it related to BugsContrib or really a core issue? Who fixed it?

-- TWiki:Main.MichaelDaum - 04 Dec 2007

Yes, I can confirm that this works now. What changes have been done in the last few days?

-- TWiki:Main.PeterThoeny - 04 Dec 2007

I believe someone has deleted a topic named "AUTOINC1".

-- TWiki:Main.ArthurClemens - 04 Dec 2007

Argh, the ItemAUTOINC1 topic is back created by FrederikBeun. And now the default topic text for bug items is gone again.

-- TWiki:Main.MichaelDaum - 05 Dec 2007

Check for existence: does not exist

-- TWiki:Main.ArthurClemens - 17 Dec 2007

ItemTemplate
Summary templatetopic parameter is ignored
ReportedBy TWiki:Main.PeterThoeny
Codebase

SVN Range TWiki-4.3.0, Sat, 24 Nov 2007, build 15734
AppliesTo Engine
Component

Priority Normal
CurrentState Closed
WaitingFor

Checkins

TargetRelease n/a
ReleasedIn

Edit | Attach | Watch | Print version | History: r11 < r10 < r9 < r8 < r7 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r11 - 2007-12-17 - ArthurClemens
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback