• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

The CPAN lib File::Spec now needs to be minimum 3.0.5

File::Spec is normally part of the standard Perl. I have tried to install an update with CPAN but that fails. The only way to upgrade it is to download sources and install it manually.

I fear this silly requirement will cause a lot of trouble for the users.

I run a Centos 4.3 equivalent to Redhat Enterprice server. And it does not meet the requirement.

Whatever new code that requires File::Spec 4.0.5 should be reverted so we can live with a much more relaxed requirement on this standard perl lib.

This may unimportant but we know by experience that this sort of problem causes a lot of trouble and if an installer is not the admin of the Unix box it will often make them give up completely.

The strange thing is that even with this error in configure, TWiki seems to work OK so I would not be surprised if the required version is not required at all.

Also note that there seem to be two different File::Specs. The one Centos 4.3 has is called 0.87 and I do not believe it is that old.

I KNOW this will cause trouble for people so it is an urgent bug.

-- KJL

I have an additional one. There are two standard lib items that are suddenly out of date on Centos 4.3.

File::Spec Error: 0.87 installed. Version 3.05 required for for base TWiki 
Time::Local Error: 1.1 installed. Version 1.11 required for for base TWiki 

I really wonder why the requirements were increased recently?

-- KJL

They weren't, conciously. I think we need to cut back the version requirement to >=0 unless there are known issues with earlier versions of the module. For example, some versions of CGI don't work....

CC

Any way to remove the dependency (in orderto cut down on the fat)?

-- PTh

No. File::Spec is a standard perl module.

CC

Version requirement reduced to 0 on both these modules.

CC

ItemTemplate
Summary Aggresive CPAN dependency with respect to File::Spec
ReportedBy TWiki:Main.KennethLavrsen
Codebase ~twiki4
SVN Range TWiki-4.1, Mon, 30 Oct 2006, build 11853
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins 11914
TargetRelease n/a
Edit | Attach | Watch | Print version | History: r9 < r8 < r7 < r6 < r5 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r9 - 2006-11-06 - CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback