• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

Fedora Core 4 is not that old but already now you cannot run configure.

I get these errors in the apache error_log

[Sat Nov 04 10:51:46 2006] [error] [client 192.168.1.9]  at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/POSIX.pm line 19
[Sat Nov 04 10:51:47 2006] [error] [client 192.168.1.9] Subroutine TWiki::Configure::Checker::tmpnam redefined at /usr/lib/perl5/5.8.6/Exporter.pm line 65.
[Sat Nov 04 10:51:47 2006] [error] [client 192.168.1.9]  at /usr/lib/perl5/5.8.6/i386-linux-thread-multi/POSIX.pm line 19
[Sat Nov 04 10:51:47 2006] [error] [client 192.168.1.9] [Sat Nov  4 10:51:47 2006] configure: Argument "1.6.0" isn't numeric in numeric lt (<) at /usr/local/apache2/twiki/lib/TWiki/Configure/Checker.pm line 207.

For some reason I do not have the error on my Centos 4.3 machine.

I fear many but not all will run into this error. And I have not myself yet found out how to get around it. I cannot see what I can change in my installation to fix it. So I set it to urgent because I believe we need to have this fixed before release.

-- KJL

This is another manifestation of Item3044. The problem is that configure depends heavily on its environment, e.g. when trying to "discover" module versions. I had tried to add the switch, but had to remove it again because of an error Item3028 which has been fixed in the meantime by CC.

I'll fix this particular error on version checking by even more restrictive filtering than I did with r11804, but I am afraid there's more like that around frown

A workaround is to either disable -w unless all those problems are fixed, or maybe better to make those warnings non-fatal - there's an explicit line in configure which makes it croak on warnings.

Please check whether r11887 fixes the problem for you, and perhaps CC can comment on whether we should remove the line

$SIG{'__WARN__'} = sub { die @_ };
and rely on people reporting warnings which appear only in the error logs.

-- haj

"rely on people"? hahhaaaahhhahaaaaaaa ROTFL

This is why I added {WarningsAsErrors} to TWiki.spec - so we could ask people to turn it on if there are warnings in the log. We should be able to use that in configure (as long as LocalSite.cfg has been read).

Changed to actioning because it is not waiting for feedback from the reporter.

CC

Sorry, I had set to waiting for feedback deliberately because I could not reproduce the error in any of my installs and wanted Kenneth to check whether my fix works for him. But okay - I manually added a fake version number of '1.6.0' to one of my CPAN libs, and the patch seems to work. I'll close this item for now, the opportunity of using TWiki::cfg{WarningsAsErrors} should be explored in a separate item, if at all.

-- haj

ItemTemplate
Summary configure will not run on a Fedora Core 4 any longer
ReportedBy TWiki:Main.KennethLavrsen
Codebase ~twiki4
SVN Range TWiki-4.1, Mon, 30 Oct 2006, build 11853
AppliesTo Engine
Component

Priority Urgent
CurrentState Closed
WaitingFor

Checkins 11887
TargetRelease n/a
Edit | Attach | Watch | Print version | History: r7 < r6 < r5 < r4 < r3 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r7 - 2006-11-05 - HaraldJoerg
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2019 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback