• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

The editor is completely broken. I installed standard Dakar release and it mostly worked. (It was functional, but a few things looked odd.) I then tried to upgrade to a newer version and it just broke. I'll post a screenshot shortly.


BrokenKupu.PNG
shows what it looks like.
Checking the javascript console I get a bunch of errors:

Error: Unknown property 'text-overflow'.  Declaration dropped.
Source File: https://wiki.pomona.edu/pub/TWiki/PatternSkin/style.css
Line: 589
Warning: The stylesheet https://wiki.pomona.edu/bin/edit/Main/WebHome?cover=kupu&t=1140245870 was loaded as CSS even though its MIME type, "text/html", is not "text/css".
Source File: https://wiki.pomona.edu/bin/edit/Main/WebHome?cover=kupu&t=1140245870
Line: 0
Error: Selector expected.  Ruleset ignored due to bad selector.
Source File: https://wiki.pomona.edu/bin/edit/Main/WebHome?cover=kupu&t=1140245870
Line: 1
Error: Found unclosed string '">'.  Found unclosed string '">'.  Unexpected end of file while searching for closing } of invalid rule set.
Source File: https://wiki.pomona.edu/bin/edit/Main/WebHome?cover=kupu&t=1140245870
Line: 212
Error: KupuButton is not defined
Source File: https://wiki.pomona.edu/pub/TWiki/WysiwygPlugin/twikitools.js
Line: 73
Error: Unknown property 'text-overflow'.  Declaration dropped.
Source File: https://wiki.pomona.edu/pub/TWiki/PatternSkin/style.css
Line: 589
Warning: The stylesheet https://wiki.pomona.edu/bin/view/Main/WebHome?skin=kupu;wysiwyg_edit=1;t=060218065815 was loaded as CSS even though its MIME type, "text/html", is not "text/css".
Source File: https://wiki.pomona.edu/bin/view/Main/WebHome?skin=kupu;wysiwyg_edit=1;t=060218065815
Line: 0
Error: Selector expected.  Ruleset ignored due to bad selector.
Source File: https://wiki.pomona.edu/bin/view/Main/WebHome?skin=kupu;wysiwyg_edit=1;t=060218065815
Line: 1
Error: Unexpected end of file while searching for closing } of invalid rule set.
Source File: https://wiki.pomona.edu/bin/view/Main/WebHome?skin=kupu;wysiwyg_edit=1;t=060218065815
Line: 34
Error: getFromSelector is not defined
Source File: https://wiki.pomona.edu/pub/TWiki/WysiwygPlugin/kupustart.js
Line: 45
Error: Unknown property 'text-overflow'.  Declaration dropped.
Source File: http://develop.twiki.org/~develop/pub/TWiki/PatternSkin/style.css
Line: 589
Error: Unknown property 'text-overflow'.  Declaration dropped.
Source File: http://develop.twiki.org/~develop/pub/TWiki/PatternSkin/style.css
Line: 589

Jefferson, I know it can be frustrating when things seem to go tits-up, but I'd be grateful if you could be a little less dramatic in your title lines, and a little more specific in your reports. I can't help unless I can reproduce the problems.

I read above that you installed standard TWiki-4.0.? - but specifically which version? 4.0.0? 4.0.1? You then say "it mostly worked". What "looked odd"? TWiki? The WysiwygPlugin? Kupu? if it was Kupu, what browser were you using? What made you say "mostly"? What did you try to upgrade to a newer version? TWiki? Kupu? From what version to what version?

CC


I downloaded 4.0.1 and used it to upgrade a 2004-Sep-04 install. At the end of that install the Wysiwyg editor mostly worked, but as I said it didn't quite look right. Below the main edit window there was a box that looked like it should have had something in it, but it didn't. (I didn't screenshot it at that point, so I'm not exactly sure what it looked like.) At that point I pulled the current version of the Wysiwyg plugin from http://twiki.org/cgi-bin/view/Plugins/WysiwygPlugin (8535) and unzipped it in my twiki folder as the install instructions say. At that point I get something that looks like the above image along with all the javascript errors above. I've tried in both Firefox 1.5.0.1 and IE 6 (with current patches).
Ok. Turns out this was a permissions error. I thought I had checked this, but turns out I made some sort of permissions errors. Sorry.

ItemTemplate
Summary (Next version of) Kupu (may be) Completely Broken
ReportedBy TWiki:Main.JeffersonCowart
Codebase

SVN Range 8535
AppliesTo Extension
Component WysiwygPlugin
Priority Urgent
CurrentState No Action Required
WaitingFor

TargetRelease major
Edit | Attach | Watch | Print version | History: r7 < r6 < r5 < r4 < r3 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r7 - 2006-02-18 - JeffersonCowart
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback