• Do not register here on develop.twiki.org, login with your twiki.org account.
• Use View topic Item7848 for generic doc work for TWiki-6.1.1. Use View topic Item7851 for doc work on extensions that are not part of a release. More... Close
• Anything you create or change in standard webs (Main, TWiki, Sandbox etc) will be automatically reverted on every SVN update.
Does this site look broken?. Use the LitterTray web for test cases.

I was going crazy trying to figure out why this was working before and then stoped - until I came across Item1009. I haven't definitely narrowed it down to this change (svn 7653) but it was working in low 7600s and stopped working in high 7600s (including beta5). So I suspect this change is the culprit.

Here's what I tested:

  • If the templatetopic is in the same web (as in TestCaseSaveContentWithoutEdit), the templatetopic will be loaded properly.
  • If the templatetopic is in another web and referenced using either a direct reference (eg Main.MyTemplate) or a variable (eg. %MAINWEB%.MyTemplate ), it will not load.

If someone investigates the code on this, you might at the same time look into Item1030 since it might be related.

LB

SVN 7653 was indeed the vortex of evil. The patch performed there was incomplete.

Fixed in SVN 8040

CC

ItemTemplate
Summary Direct save not recognizing templatetopic reference in another web.
ReportedBy TWiki:Main.LynnwoodBrown
Codebase

SVN Range Tue, 27 Dec 2005 build 7999
AppliesTo Engine
Component

Priority Normal
CurrentState Closed
WaitingFor

Checkins 8040
Edit | Attach | Watch | Print version | History: r4 < r3 < r2 < r1 | Backlinks | Raw View | Raw edit | More topic actions
Topic revision: r4 - 2005-12-30 - CrawfordCurrie
 
This site is powered by the TWiki collaboration platform Powered by PerlCopyright © 2008-2018 by the contributing authors. All material on this collaboration platform is the property of the contributing authors.
Ideas, requests, problems regarding TWiki? Send feedback